Get in touch
Back
Resolved

Brief Outage in Backend File Processing Queue

Started 20 May at 07:47am HDT.

API Widget
Created

We experienced a temporary disruption in our backend file processing queue following a recent upgrade. The issue has been identified and promptly resolved. All systems are now operating normally.

Posted 20 May at 07:47am HDT.